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CONVERTING FRAMEMAKER 
FILES TO PROCEDURE 
GENERATOR FORMAT 
In five easy steps… 
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Agenda 
1.  Mif2Go Overview 

2.  Conversion Process Overview 

3.  Conversion Process Architecture 

4.  My First Conversion At-A-Glance 

5.  What to Do With Each New Product Release 

6.  Buying Mif2Go 
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Mif2Go Overview  
•  Fast, accurate, and least expensive way to convert 

FrameMaker files to HTML, XML, printable Word RTF, 
HTML Help, and many more Help formats! 

• Supported 
–  FrameMaker 9, 8, 7.2, 7.1, 7.0, 6, or 5.5 
–  Win2K, XP, Vista, or 7 (WinNT, 9x, and ME also supported) 

• UNIX and Mac versions not available 

• www.mif2go.com 
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Conversion Process Overview 

FrameMaker 
• Only relevant if your 

source files are: 
•  In *.FM format 
• Based on EMC 

templates  
(use EMC style names) 

• Review new/modified 
texts,  handle images 
and add module 
breakup in FM files 

Mif2Go   
(a FM plug-in) 
• Select the path to the 

mif2rtf.ini (one time) 
• Run conversion process 

Word Macros 
• Open each RTF file 
• Apply PG style template, 

and attach macro 
template 

• Run macros to clean up, 
and break into modules 

Procedure Generator 
• Send *.doc files to Dylan 

Kim 

*.DOC 
*.RTF 

*.FM 
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Conversion Process Architecture 

The Mif2rtf.ini 
contains the 
conversion 
settings.  
 
Use the Mif2Go 
User Guide to play 
with the Mif2rtf.ini. 
 
Note: If you delete 
the Mif2rtf.ini from 
the Output folder 
the process wont 
run.  
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My First Conversion At-A-Glance 
1.  Get the files 

2.  Install Mif2Go 

3.  Copy templates to Microsoft Templates dir 

4.  Create the source file infra and convert 

5.  Clean up, apply PG styles and break up into modules 
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Get the Files 
a)  Copy the Mif2Go and ProcedureGenerator  

folders and their contents from: 

! !//COE_Public/IDD/PGtoFM/ !

b)  Paste them onto your C:\ drive “as-is”. 

1 
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            C:/ProcedureGenerator/Mif2Go/  
             Mif2Go UNLICENSED Software/!

Mif2Go 
Distribution 
Folder 

Install Mif2Go 2 

Open Windows explorer and navigate to the Mif2Go distribution folder: 
C:/ProcedureGenerator/Mif2Go/Mif2Go UNLICENSED Software/ 
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Perform a Mif2Go Test Run 
In FrameMaker: 
•  Open C:\ProcedureGenerator

\Sources\ Tutorial\SampleFile.fm 
•  Select File > Set Up Mif2Go Export 

> in the Choose Project dialog box: 
–  Next to Path, select the button with 

the elipses […] 
–  Browse to C:\ProcedureGenerator

\Output 
–  Click OK twice 

•  Select File > Save Using Mif2Go, 
and click the OK button. 

•  Browse to the Output folder and 
look for SampleFile.rtf. 

2 
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Install Word Macros and Templates 
Copy all folders and files in: 

 C:\ProcedureGenerator\00Templates\Word Templates and Macros\!

 

 

 

 

 

 

…and paste them to your Microsoft Office Templates dir: 
For example:  

C:\Users\<user>\AppData\Roaming\Microsoft\Templates\!

!

3 
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Create Source File Infra and Convert 
To create the PG infrastructure in the source file: 

a)  Open the file you want to convert and SampleFile.fm 

b)  Import formats from SampleFile.fm 

c)  Mark start and end of PG modules 

d)  Handle images 

e)  Control what is displayed 

f)  Convert Yourfile.fm to RTF using Mif2Go 

4 



12 EMC CONFIDENTIAL—INTERNAL USE ONLY. 

Before you Begin - Ping Dylan 
1.  Send Dylan Kim an email 

with a PDF of the file that 
contains content required 
for PG.  

2.  Open the PDF sent to you 
by Dylan Kim. Look for 
highlighted sections with a 
sticky note including the 
filename of the required PG 
module. 

3.  Use the PDF to identify the 
PG modules’ name, start 
and end in your source file. 

4 
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a) Open YourFile.fm and SampleFile.fm 
In FrameMaker: 

Open C:\ProcedureGenerator\ 00Templates\ 
SampleFile.fm and the file you want to convert (we 
will refer to this file as YourFile.fm) 

NOTE: If you wish to convert multiple files 
simultaneously, create a book and add all of the files 
that you wish to convert to the book (we will refer to 
this file as FilesToConvert.book).  

4 
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b) Import Formats from SampleFile.fm 
Put the cursor focus on 
YourFile.fm or all of the files in 
FilesToConvert.book and 
select File > Import Formats  
a)  In the Import from 

Document drop-down > 
select SampleFile.fm 

b)  Check ONLY the Paragraph 
Formats, Color Definitions 
and Conditional Text 
Settings checkboxes 

c)  Click Import 

4 
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Tip 
Turn on text symbols  
Select View > Text Symbols 

 

Show conditional text dialog box 
Select Special > Conditional 
Text > Conditional Text… 
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Use the PDF from Dylan to know which modules you need.  
At a module’s start insert %START_<PGModuleName.doc>% 

 

For example:  

If you want to name the module Product_Release_Procedure.doc insert: 
 %START_Product_Release_Procedure.doc%!

At a module’s end insert %STOP% 

For these tags to work, you must: 

•  apply the Show in Procedure Generator condition. 

•  apply the PGBreaks paragraph format. 

•  Not include spaces in the filenames. 

 

c) Mark Start and End of PG Modules 4 
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c) Example 4 
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d) Handle Images 
•  Every graphic must be in an anchored frame and the 

anchored frame must be in a one of the anchor paragraph 
formats (z1Anchor, z2Anchor, z3Anchor) 

•  Every graphic must be imported twice: 
–  In the resolution for print (I use 96 dpi, the default screen dpi) 
–  In the resolution for PG (I use 250 dpi) 

•  Apply the Hide in Procedure Generator condition to the 
zAnchor paragraph tag, the anchored frame and the image 
that are meant for print. 

•  Apply the Show in Procedure Generator condition to the 
zAnchor paragraph tag, the anchored frame and the image 
that are meant for PG. 

4 
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e) Decide What Isn’t Displayed 
Apply Hide in Procedure Generator condition to hide any 
content that IS NOT required in the PG output, such as: 
•  Any zAnchor paragraph tags, anchored frames and images 

that are meant for print. 
•  Any references to documents or procedures outside of the 

current procedure. For example: See the xxx Guide for 
more info. 

•  Footnotes (number/letter and text). Footnotes in tables 
must be recreated for PG. Create a number/letter in the 
Cell style of the text being footnoted, and add text in Body 
style directly below the table. Keep the same numbering 
and text as the original footnote. 

4 
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e) Hide Text in PG Example 
Apply Hide in Procedure Generator condition to any 
content that is NOT required in the PG output. 

4 
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e) Decide What is Displayed 
Apply Show in Procedure Generator condition to any 
content that IS required ONLY in the PG output (and not in 
your other files), such as: 

•  The %START% and %STOP% tags. 

•  Any zAnchor paragraph tags, anchored frames and images 
that are meant for PG. 

•  Footnotes in tables must be recreated for PG. Create a 
number/letter in the Cell style of the text being footnoted, 
and add text in Body style directly below the table. Keep 
the same numbering and text as the original footnote. 

4 
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e) Show Text in PG Example 4 
Apply Show in Procedure Generator condition to any 
content that is ONLY required in the PG output. 
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f) Convert Yourfile.fm to RTF 
•  In FrameMaker > select File > Save Using Mif2Go,  

and click the OK button twice. 
–  NOTE: You can use the Set Up Mif2Go option before you 

Save Using Mif2Go and define a different Output folder, 
but you must copy the mif2Go.ini to any Output folder you 
create. 

• Open the C:\ProcedureGenerator\Output folder and 
look for Yourfile.rtf. 

4 
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Clean up, Apply Styles and Break-up 
This part is performed in Word.  
In this part of the process, you will: 

a)  Open your converted file/s (Yourfile.rtf) in Word 

b)  Attach the PG templates 

c)  Run macros to clean up the converted file/s 

d)  Run the PG1 macro to create the PG modules 

5 
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a) Open the Converted File/s 5 

NOTE: It is important that you perform these steps  
exactly as they are written or the outcome may be unexpected. 

1.  Open MSWord* 

2.  Select the Office Button  (      ) and select Open 

3.  Browse to the PG Output folder, and select 
Yourfile.rtf. 

* You MUST open Word first and only then your file. 
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b) Attaching the Templates 1/2 
Display Word Options 
1.  Click Office Button  
2.  Click Word Options  
 

 
 
 
 
 
Display Templates and Add-ins dialog box 
1.  Select Add-Ins 
2.  In the Manage Drop-Down, select 

Templates 
3.  Click Go… 

5 
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b) Attaching the Templates 2/2 

1.  Click Attach… > Select 
CelPG_Styles_temp14_4.dot 

2.  Check the Automatically 
update document styles 
checkbox 

3.  Click Add… > Select 
CellPG_Macros_temp1_6.dot 
and click OK 

4.  Click Add… > Select PG.dotm 
and click OK  

5 
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c) Cleaning Up The Converted File/s 
1.  Select the Developer Tab 
2.  Click Macros 

The Macros dialog box 
appears. 

5 

3.  Run the following macros to 
clean up your file, and set 
up the page structure: 
–  RemoveAllBookmarks 
–  Delete_char_styles 
–  Delete_unused_styles_v2 
–  PageSetupCelPG 
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d) Creating PG Modules 
1.  Select the Developer Tab 
2.  Click Macros 

5 

3.  Run the PG1 macro to 
break up your *.rtf file into 
PG modules with a *.doc 
extension. 

The modules are created in the same folder as your RTF file. 
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What to Do With Each New Product Release 
1.  If there is new content (sections): 

a)  A week before you go to publish, send Dylan Kim a PDF with 
change bars or track changes on any new sections/chapters. 

b)  Dylan will send you an email if he needs any extra modules 
created for the new content. 

2.  Open the file you wish to convert in FM: 
a)  If this file doesn’t already contain the PG infrastructure: 

Import paragraph formats, conditional settings and color 
definitions from a file containing them. Otherwise: 

b)  Show the conditions: Show in Procedure Generator and Hide 
in Procedure Generator 

c)  Turn on Condition Indicators 
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What to Do With Each New Product Release 
3.  If Dylan needed new sections, add the appropriate 

%START% and %STOP% tags. Otherwise: 

4.  Look for new images, and handle appropriately. 

5.  Look for new/changed footnotes, and handle 
appropriately. 

6.  Ensure conditions are applied correctly. 

7.  Look for added references to external materials, and 
condition them out.   
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What to Do With Each New Product Release 
8.  Save Using Mif2Go 

9.  Open Word, then open the converted RTF file, and 
attach the templates. 

10. Check that the RTF file came out well, if not, fix the 
FM file and go back to step 8. 

11. Run the macros for file cleanup and pagination. 

12. Run the PG1 macro to break the RTF file into PG 
(*.doc) modules. 

13. Send the *.doc files to Dylan. 
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Buying Mif2Go 
• Buy Mif2Go 

–  Single-seat license is $295; annual renewal $75 
–  Pricing for multiple copies and site license: 

http://www.omsys.com/dcl/pricing.htm 
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THANK YOU 


